Description
Stored XSS vulnerability in the media plugin. Attackers can inject malicious scripts via elements crafted through the data-mce-object attribute, which are created and executed before sanitization. Impacts users of TinyMCE with the media plugin enabled.
Recommendation
Update the tinymce package to the latest compatible version. Followings are version details:
Affected version(s): **= 7.9.3 >= 8.5.1, < 8.9.3** Patched version(s): **7.9.4 8.9.3**
References
Could your website be exposed too?
SmartScanner can check your website for TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` serialization and gives you actionable findings to investigate.
Start a free scanRelated Issues
- TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` injection - CVE-2026-47761
- TinyMCE Cross-Site Scripting (XSS) vulnerability using through data-mce- prefixed src, href, style attributes - CVE-2026-47759
- TinyMCE Cross-Site Scripting (XSS) vulnerability using sanitization bypass through nested SVGs - CVE-2026-47760
- TinyMCE Cross-Site Scripting (XSS) vulnerability through `mce:protected` comments - CVE-2026-47762


