Description
A user can submit a request that exploits a SQL Injection vulnerability in Payload.
You are affected if:
- You use an affected Payload version.
- Untrusted users can query readable collections using dynamic filters or joins.
You are not affected if you use MongoDB (@payloadcms/mongodb).
Recommendation
Update the payload package to the latest compatible version. Followings are version details:
Affected version(s): **>= 4.0.0-canary.0, < 4.0.0-canary.27 >= 3.0.0, < 3.88.0** Patched version(s): **4.0.0-canary.27 3.88.0**
References
Could your website be exposed too?
SmartScanner can check your website for Payload: SQL Injection in SQLite and Postgres and gives you actionable findings to investigate.
Start a free scanRelated Issues
- Payload has an SQL Injection via Query Handling - CVE-2026-34747
- @payloadcms/drizzle has SQL Injection in JSON/RichText Queries on PostgreSQL/SQLite Adapters - CVE-2026-25544
- Kysely has a MySQL SQL Injection via Insufficient Backslash Escaping in `sql.lit(string)` usage or similar methods that - CVE-2026-33468
- Kysely has a MySQL SQL Injection via Backslash Escape Bypass in non-type-safe usage of JSON path keys. - CVE-2026-33442
You might also like:
See something that needs correcting? Let us knowUpdated October 06, 2026


