Vulnerability library
Security checkOctober 27, 2026

CKEditor: Cross-site scripting (XSS) in the engine package - @ckeditor/ckeditor5-engine

Understand the exposure, see the recommended fix, and check whether your own website has related weaknesses.

Check your website

Find this and other vulnerabilities with a free scan.

Your scan runs on your computer. No account required.

Description

A Cross-Site Scripting (XSS) vulnerability has been discovered in the CKEditor 5 engine.

Recommendation

Update the @ckeditor/ckeditor5-engine package to the latest compatible version. Followings are version details:

  • Affected version(s): **>= 48.0.0, < 48.5.1 >= 29.0.0, < 47.7.4**
  • Patched version(s): **48.5.1 47.7.4**

References

Could your website be exposed too?

SmartScanner can check your website for CKEditor: Cross-site scripting (XSS) in the engine package - @ckeditor/ckeditor5-engine and gives you actionable findings to investigate.

Start a free scan

Related Issues

See something that needs correcting? Let us knowUpdated October 27, 2026